Delayed Check Runs in Johannesburg, South Africa
Incident Report for Rigor
Resolved
Azure has completed their remediation and this incident has been resolved.
Posted Mar 16, 2024 - 20:58 EDT
Update
Azure has updated the estimated time to complete fix to 14:00 UTC on 15 Mar 2024.
Posted Mar 15, 2024 - 08:41 EDT
Monitoring
Azure is currently estimating 4 hours for a fix. Metrics may still be higher in the Johannesburg, South Africa location, but we are processing jobs in real time. We'll continue to monitor the situation.
Posted Mar 14, 2024 - 15:50 EDT
Identified
The current estimate for the completion of the remediation efforts is estimated to be at least 12 hours. We may continue to see degraded performance during that time.
Posted Mar 14, 2024 - 11:08 EDT
Update
The provider has identified the issue is with multiple fiber cables on the West Coast of Africa as well as on-going fiber cable cuts in the Red Sea. This has impacted all of Africa's capacity for multiple providers and the public Internet.

For status updates, please see https://azure.status.microsoft/
Posted Mar 14, 2024 - 10:02 EDT
Investigating
We are experiencing delayed test execution in our Johannesburg, South Africa location. Users may see gaps between check runs in this location and metrics from those runs may be higher than normal.

We will monitor the provider's status page and provide updates.
Posted Mar 14, 2024 - 07:55 EDT
This incident affected: Rigor Monitoring Network - Africa (Johannesburg, South Africa).