Optimization website down
Incident Report for Rigor
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 03:21 EDT
Investigating
We are currently investigating this issue.
Posted Jun 21, 2022 - 03:14 EDT
This incident affected: Rigor Optimization (Application Website (https://optimization.rigor.com)).