Delayed results from N. California
Incident Report for Rigor
Resolved
Our N. California location is no longer experiencing a delay in performing test checks.
Posted Nov 13, 2017 - 18:23 EST
Update
We are continuing to monitor the delayed execution of checks from our N. California location. The delay began at 20:22 UTC (3:22 PM EST). Please note that test results are not affected.
Posted Nov 13, 2017 - 16:43 EST
Monitoring
We are seeing delayed execution of RBC checks in our N. California location. We have taken action to address the issue and are monitoring the region.
Posted Nov 13, 2017 - 15:53 EST