Delayed results from N. California
Incident Report for Rigor
Resolved
Our N. California location has recovered and is now processing check runs without delay.
Posted Nov 15, 2017 - 15:45 EST
Identified
We are experiencing delayed test execution in our N. California location due to issues with our provider. We are working to allocate additional resources to expedite processing. Delays began at around 2:15 PM EST (19:15 UTC).
Posted Nov 15, 2017 - 14:45 EST