Delayed Runs in Shanghai, China
Incident Report for Rigor
Resolved
This incident has been resolved.
Posted Jan 21, 2021 - 12:28 EST
Investigating
We are currently investigating delayed check runs in our Shanghai, China monitoring location. You may see gaps in your check data from this location until the issue is resolved.
Posted Jan 21, 2021 - 09:22 EST