Services impacted due to AWS outage

Incident Report for Rigor

Resolved

All Rigor monitoring has returned to normal and AWS has updated status to "resolved."
Posted Oct 20, 2025 - 19:57 EDT

Monitoring

As AWS monitoring is coming back online, we can see that run scheduling has been continuing as normal, despite the AWS outage.
Posted Oct 20, 2025 - 04:55 EDT

Investigating

We are currently investigating the issue, including what is being reported by AWS: https://health.aws.amazon.com/health/status?path=open-issues.
Posted Oct 20, 2025 - 04:29 EDT