Delayed Checks in Beijing
Incident Report for Rigor
Resolved
This incident has been resolved.
Posted Aug 16, 2019 - 02:42 EDT
Identified
We're experiencing a delay in execution of checks from our Beijing location. We are working to scale up resources in this location. You may continue to see delayed check execution until our services have fully recovered.

We will provide additional updates as appropriate
Posted Aug 16, 2019 - 02:21 EDT
Monitoring
We're experiencing a delay in execution of checks from our Beijing location. We are working to scale up resources in this location. You may continue to see delayed check execution until our services have fully recovered.

We will provide additional updates as appropriate
Posted Aug 16, 2019 - 02:16 EDT