Domain Performance Reports are down
Incident Report for Rigor
Resolved
Issue has been identified and domain performance reports are back. No data was lost.
Posted Sep 18, 2017 - 16:24 EDT
Investigating
This only affects the UI, no data should be lost.
Posted Sep 18, 2017 - 16:10 EDT